The comparison of two programmes to measure color difference (ΔE) from tooth sample photo

Mutiara Annisa*, Harsini*, Archadian Nuryanti**

*Faculty of dentistry, Department of Dental Biomaterial, Universitas Gadjah Mada
**Faculty of dentistry, Department of Dental Biomedical Sciences, Universitas Gadjah Mada

Correspondence: mutiara.annisa@mail.ugm.ac.id

ABSTRACT

**Background:** Color evaluation is crucial to evaluate a material's quality. One alternative method for evaluating material's color is using photographs analysed by software. This research evaluates the use of digital imaging and software (ImageJ and Photoshop) to obtain color differences of tooth sample in-vitro.

**Methods:** The sample used is bovine teeth that were given tea-staining and brushing treatment using five tested toothpastes. Sample’s photographs for each toothpaste’s group (n=4) were taken before and after experiment. DLSR Nikon D90 was used with digital CCD censor, macro lens 105mm, manual setting (ISO 200, F-Stop 5, Shutter Speed 1/400) with distance to sample of 25cm. Sample was positioned in foldable mini-studio-box (24.5x24.5x22.5cm) with LED-lighting (6500-7000 color temperature). The photographs were taken in close room at 11.00am. Two software were used to obtain the color value from pre- and post-experimental photographs of the sample at the middle-third of the sample using Commission Internacional de l’Eclairage L*a*b (CIE-Lab) color system. The resulted color difference (ΔE) value of sample from the two-software were compared using independent T-test and evaluate the measurement accuracy using Pearson’s correlation (α=0.05).

**Results:** ImageJ and Photoshop analyses of the sample photographs yield comparable ΔE values, as determined by an independent T-test (p=0.893). The Pearson correlation test reveals a positive correlation (R=0.904) between the two software.

**Conclusion:** The use of digital photography and software to obtain ΔE values are accurate, representative, and recommended when taking into account the controlled procedure of photographing the sample and analysing the sample's color value.

Keywords: Color perception test; photography; CIELab; ImageJ; Photoshop

Copyright ©2023 National Research and Innovation Agency. This is an open access article under the CC BY-SA license (https://creativecommons.org/licenses/by-sa/4.0/).

doi: http://dx.doi.org/10.30659/odj.10.2.257-267
2460-4119 / 2354-5992 ©2023 National Research and Innovation Agency
This is an open access article under the CC BY-SA license (https://creativecommons.org/licenses/by-sa/4.0/)
Odonto: Dental Journal accredited as Sinta 2 Journal (https://sinta.kemdikbud.go.id/journals/profile/3200)
How to Cite: Annisa et al. The comparison of two programmes to measure color difference (ΔE) from tooth sample photo.
INTRODUCTION

Color is one of the important physical properties in dentistry materials. In dentistry material field researchs, color is often considered to be the success or failure of a material. With the emerging of aesthetics, color evaluation has been conducted extensively both in vitro and clinically, one of which is the test of material color stability against factors causing color difference. Color stability tests are commonly conducted on restorative materials, veneers, artificial teeth, denture base and provisional restorative material. Beside the color stability, color difference test is often conducted to evaluate the success of materials as bleaching agents, cleansing agent, or whitening toothpastes, for example to evaluate the effect of certain toothpaste as extrinsic stain cleanser or whitener. In the clinical practice, color evaluation is often conducted to evaluate the success of treatment, either bleaching, restoration, and so on. Color evaluation is also conducted in dentistry practice in shade determination and shade matching for a restoration.

Color evaluation can be conducted with visual and instrumental methods. Clinically, visual color evaluation is conducted using shade guide by comparing the color of the patient's teeth to the standard color on the shade guide. In the field of research, the visual color evaluation such as color difference test of teeth or material is performed directly using the perception of the naked eye observer. The results are then classified as slight, moderate, or severe color difference. This test can be conducted directly on the specimens or by comparing photographs taken before and after treatment. The subjectivity of the observer due to variables such as ambient light conditions, mesmerism, light reflection, eye fatigue, color-blind, and individual perception of color are some of limits of these visual method. To overcome the limitations of visual methods, instrumental methods have been used to obtain quantitative color information. Colorimeters, spectrophotometers, and chromometers are examples of instruments that are frequently used. The instrument can be calibrated and standardized, and the observer obtains the color value immediately. One example of color value quantification is using CIELab color system. This color system measures optic spectra reflection on a specific wavelength of light and represent it to certain number based on lightness or luminance (L), a* and b* coordinates, where L value is lightness of teeth or material with value of 0 indicating dark and 100 indicating light. The a* value indicates redness (negative a*) and greenness (positive a*), and the b* value shows yellowness (negative b*) and blueness (positive b*). The limit of instrument method is there is no photograph documentation of specimen, because the color value appeared immediately through the instrument when conducting color evaluation. Furthermore, the instruments are typically available in laboratories, which are occasionally not present in particular places. The use of instruments is also technique sensitive, with some color quantification biases occurring as a result of unintentional operator error when using the instrument.

One of the alternative approaches for quantifying color value is the use of digital imaging with software. By using this method, visual information from the photograph of the specimen tested can be obtained in addition to the quantitative color value that is calculated using software from the photograph taken. Along with the instrument method, the use of software can acquire the La*b* color value by converting the photograph to the CIELa*b* color system. After obtaining the values of L, a*, and b*, some calculations relating to color properties, such as color difference or color stability (ΔE), can be conducted. This method can
be conducted using various software, including ImageJ and Photoshop. ImageJ is a quick, objective, and repeatable technique for quantifying color value as long as Photoshop graphic analysis program supports the CIEL*a*b* color system. However, just a few references exist that explain the use of digital imaging and software in color test and its accuracy compared to instruments method. This research aims to provide detailed information regarding the use of digital imaging and software, including step-by-step procedures, as well as to evaluate the measurement of color difference (ΔE) produced from this method.

**RESEARCH METHODS**

**Ethical aspect**

The ethics and advocacy commission of the Faculty of Dentistry, Universitas Gadjah Mada, approved this study with the ethical clearance number No.00778/KKEP/FKG-UGM/EC/2021.

**Sample Size Determination and Sample Preparation**

This *in-vitro* experimental research evaluates the use of digital imaging and software to determine the color difference of bovine teeth before and after the experiment. The experiment comprises of tea staining of the bovine teeth followed by brushing with five different toothpastes to determine the ability of the toothpaste to remove the tea stain and restore the color of the bovine teeth to its pre-experimental state. The sample size was calculated using a sample size determination formula with a 95% confidence level. The sample size for each toothpaste group was four (n=4). Table 1 shows the toothpastes used in this investigation and their composition.

**Table 1. Group of Toothpastes and their compositions.**

<table>
<thead>
<tr>
<th>Group</th>
<th>Type of Toothpaste</th>
<th>Composition</th>
</tr>
</thead>
<tbody>
<tr>
<td>FA</td>
<td>Formulated toothpaste with 0% v/v bay leaf essential oil as negative control</td>
<td>Carbopol 940, triethanolamine, sodium benzoate, tween 80, glycerin, aquades</td>
</tr>
<tr>
<td>FB</td>
<td>Formulated toothpaste 0.125% v/v bay leaf essential oil</td>
<td>Carbopol 940, triethanolamine, sodium benzoate, tween 80, glycerin, aquades, bay leaf essential oil 0.125% concentration</td>
</tr>
<tr>
<td>FC</td>
<td>Formulated toothpaste 0.25% v/v bay leaf essential oil</td>
<td>Carbopol 940, triethanolamine, sodium benzoate, tween 80, glycerin, aquades, bay leaf essential oil 0.25% concentration</td>
</tr>
<tr>
<td>FD</td>
<td>Formulated toothpaste 0.5% v/v bay leaf essential oil</td>
<td>Carbopol 940, triethanolamine, sodium benzoate, tween 80, glycerin, aquades, bay leaf essential oil 0.5% concentration</td>
</tr>
<tr>
<td>FE</td>
<td>Commercial toothpaste as positive control</td>
<td>Calcium carbonate, hydrated silicate, 0.7% perlite, aluminium oxide, sorbitol as a humectant, sodium lauryl sulphate (SLS), flavouring, 1.12% sodium monofluorophosphate, gum cellulose, sodium saccharine, potassium citrate, water, DMDM hydantoin preservatives, and the coloring agent (CI 74160 and CI 76891)</td>
</tr>
</tbody>
</table>
The bovine teeth samples were soaked in 0.7% thymol solution for 24 hours before the pre-experimental photo was taken. Bovine teeth from 2–3-year-old calves were obtained at the Mancasan slaughterhouse. The teeth used were maxillary incisors with smooth surfaces, no stain or fracture, and homogeneity color (A3-A3.5 color perceived using Vita®Shade Guide) were utilized. To achieve a flat surface, the bovine teeth were attached in dental wax.

**Photo Taking Procedure**

Nikon D90 DSLR camera with digital CCD censor, 105mm Macro Lens, setting was conducted with Operation mode manual guide, ISO 200, F-Stop 5, and Shutter Speed 1/400. The camera was placed on a tripod with a distance of 25 cm, an angle of 0° from the object. Bovine teeth was placed on the 24.5x24.5x22.5 cm foldable mini studio box, with LED light 20 LED bulbs lighting which have 6500-7000 color temperature. The photo taking was conducted indoors at 11.00.

A total of 20 bovine teeth samples were photographed with 3 repetitions for each sample. A selection was conducted towards photos that were out of focus and blurry, then the photo taking was redone. The photo taking was conducted twice, which were: a) before the treatment to obtain the color baseline of each sample and b) after treatment, which was after the bovine teeth were stained by with tea and brushed with toothpaste.

**CIELAB Color Quantification with Software and Color Difference Calculation**

The photos obtained were analyzed using ImageJ® freeware (http://imagej.nih.gov/ij) and Adobe Photoshop® CC 2019. Color analysis was conducted to obtain L, a, b values of photo before treatment and after treatment to conduct color difference calculation. Whole photos were converted into png format.

**CIELAB Color Quantification with ImageJ**

Analysis with ImageJ was conducted with the procedure that first the photo which was still in the form of an RGB image was converted to a LAB image with menu Image → Type → Lab Stack. The photo will be splitted into 3, which are L*, a*, and b*. Next, the grid could be displayed using menu Analyze → tools → grid with an area of 2000 pixel per point. Rectangle selection was conducted to the middle of the teeth following the existing grid. The L value was obtained by clicking menu Analyze → Measure. Mean value which is appear in the result window was recorded as L value. Do the same step to photo a* and b* to obtain a* and b* value. Step by step procedure along with the image descriptions is presented in table 2.

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open ImageJ freeware, drag and drop the photo.</td>
<td></td>
</tr>
</tbody>
</table>

---

*Table 2. Step-by-step protocol for L*a*b* color measurement using ImageJ.*

The comparison of two programmes to measure color difference (ΔE) from tooth sample photo

Convert the RGB image to Lab type by using menu of Image → Type → Lab Stack.

The image will be converted to Lab type, indicated by 3 separate images of L*, a*, and b* (red circled).

To obtain the L*, a*, and b* values, make a selection of the part of the teeth to be measured. To perform a controlled selection between the before and after experiment, the grid can be showed by Analyze → Tools → Grid.

Adjust the area of grid into 2000 pixels.

Make a selection by using rectangle (click the rectangle icon in the corner of the menu) and select the middle part of the teeth (red arrow).
To obtain the L* value, click Analyze → Measure, and the result will be showed as follows. The mean is the L* value to be noted and used to calculate the color difference.

To obtain the a* color, click the right arrow below the picture to switch into a* picture. Then click Analyze → Measure again, the a* color will be showed in the result.

The same way is also done for b* color.

Record each measurement and do for all pictures.

**CIELAB Color Quantification with Photoshop**

The procedure of quantifying color with Photoshop was opening the image to be analyzed, then converting it to a Lab type by clicking Image → Mode → Lab color. Bring up the grid to ease the matching process of teeth parts to be analyzed by clicking View → Show → Grid. Conduct the color analysis to the target part with eyedropper tool on the left. The Lab value will appear on the right. Step-by-step protocol is presented on Table 3.

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open photoshop freeware, drag and drop the photo. Convert the RGB image to Lab type by using menu of Image → Mode → Lab color.</td>
<td></td>
</tr>
</tbody>
</table>
Show the grid by clicking View → Show → Grid.

Click the eyedropper tools (red circled), then click on the area of analysis (the center of the tooth). The Lab value will be showed on the right side (red arrow).

Record each measurement and do for all pictures.

**Color Differences Calculation**

The color differences present the color alteration of sample before experiment ($L_1$, $a_1$, $b_1$) and after brushed on post stained-teeth ($L_2$, $a_2$, $b_2$), so that the lower the tooth color difference, the better the performance of the toothpaste, because the toothpaste can restore the color of stained teeth to the initial color. The formula to obtain the color difference is as follows:

$$
\Delta E = \sqrt{(L_2 - L_1)^2 + (a_2 - a_1)^2 + (b_2 - b_1)^2}
$$

**Data Analysis**

The data obtained from this study are in the form of color differences ($\Delta E$) value resulted from 5 toothpastes used, which are 2 control toothpastes and 3 treatment toothpastes which is obtained from the Lab values of two software, which are ImageJ and Photoshop. In evaluating the accuracy of two software to quantify the $\Delta E$ value, a Pearson's correlation test was conducted to determine the closeness of the results obtained from the two software. In addition, an independent T-test was conducted to find out whether the $\Delta E$ value resulted by the two software was significantly different. Previously, normality and homogeneity test was conducted to the data. The 95% trust level was used in this study.

**Results**

The color difference ($\Delta E$) value indicates the change of tooth color before treatment and after treatment, which is brushed with toothpaste after being stained with tea. Mean and deviation standard of tooth $\Delta E$ value obtained from the calculation of $L$, $a$, $b$ values of each software for each group is presented in table 4.

<table>
<thead>
<tr>
<th>Type of Toothpaste</th>
<th>$\Delta E$ Value</th>
<th>ImageJ</th>
<th>Photoshop</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formulated toothpaste 0% v/v bay leaf essential oil (negative control)</td>
<td>14.47 ± 1.90</td>
<td>12.34 ± 1.49</td>
<td></td>
</tr>
<tr>
<td>Formulated toothpaste 0.125% v/v bay leaf essential oil</td>
<td>9.15 ± 2.06</td>
<td>7.86 ± 0.95</td>
<td></td>
</tr>
<tr>
<td>Formulated toothpaste 0.25% v/v bay leaf essential oil</td>
<td>5.46 ± 0.81</td>
<td>6.34 ± 0.88</td>
<td></td>
</tr>
<tr>
<td>Formulated toothpaste 0.5% v/v bay leaf essential oil</td>
<td>3.47 ± 1.06</td>
<td>4.85 ± 1.43</td>
<td></td>
</tr>
<tr>
<td>Commercial toothpaste (positive control)</td>
<td>3.45 ± 0.66</td>
<td>4.20 ± 1.23</td>
<td></td>
</tr>
</tbody>
</table>
Table 4 shows a decrease in the ΔE value, along with the increase of bay leaf essential oil concentration in toothpaste. Both are resulted from Lab value analyzed with imageJ and photoshop. The Pearson’s correlation test was conducted to test the accuracy of both test by knowing the relationship between the two tests. There is strong correlation between ΔE value resulted from imageJ and photoshop (R=0.904; Figure 1). The data of ΔE value was tested with independent t-test to compare the average of ΔE values obtained from the two types of software. The results of the independent t-test were obtained with a significance of p=0.893.

**Figure 1.** Pearson correlation analysis of ΔE value obtained from ImageJ and Photoshop software, with coefficient correlation of R=0.904

**Discussion**

This research aims to provide detailed information on the use of digital imaging and software and to evaluate the result of measuring color difference (ΔE) resulted from digital imaging which was conducted Lab analysis using two software. In this research, the color differences value is used to determine the ability of 5 types of toothpastes (Table 1) in cleaning the stain resulted from tea. Color differences value was obtained from the calculation of L, a, b values which are obtained from photos which were quantified with ImageJ and photoshop. The photo taking process was conducted using digital camera in controlled manner to all samples in each group, and three repetitions were conducted for each sample. Digital cameras are used because they are image-producing devices that are easily available, easy to control, and easy to apply both for research or in dental photography in clinic. The previous research has shown that the use of digital camera is more reliable and controllable for analysis and color selection than visual method. The controlled variables in this research including the sample used, photo taking procedure in the form of camera setting, the position of the camera to the object, the time of taking photo, lighting, and the procedure of color analysis using software, which is using the same area to conduct analysis before and after treatment.

The use of digital imaging and software is an alternative method of instruments such as spectrophotometer, colorimeter, and chromameter which are commonly used in laboratories. The use of chromameter has advantages such as standardized, calibrated, and objective in quantifying...
tooth color. When used properly, chromameter can provide accurate color measurement results and are not influenced by disturbing factor such as lighting and subjectivity of color perception. The challenge in using this instrument is that the technique is sensitive, which requires a flat sample surface so that the chromameter base plate can attach directly to the sample, this caused the sample used required special preparation. In addition, the entire aperture of chromameter must be covered by the sample, otherwise the results will be biased, making it difficult to use for samples that are small and have uneven surfaces. The chromameter is less feasible to use in the clinic due to its quite large size and requires sample preparation by making the sample surface flat, and difficult to use for malpositioned teeth. The constraints are also experienced in the use of the spectrophotometer. This instrument measures the color of the teeth in certain points or is referred to as point measurement, so that it is less representing the overall color of the teeth. In addition, if it is used clinically directly to the patient, it is less beneficial from hygienic point because it will have contact and attach directly to the tooth surface. Both the chromameter and the spectrophotometer also only provide color quantification results, there is no image documentation. CIELab color space is used with principle of dividing the lightness value and two chromatic values separately, so that it can provide more accurate human color perception, the closest approximation, and is linearly related to eye natural responses. CIELab can express wider range of colors than RGB, which is suitable for specific analysis and color evaluation of a material. The previous research used CIELab system to quantify teeth color difference after treatment with certain materials, which resulted in good color quantification and represented the brightness of the teeth and the tendency of teeth yellowing through L and b values.

The software used in this research are ImageJ and photoshop. ImageJ is an image analysis program created by the National Institutes of Health. ImageJ is a simple, fast, objective, and reproducive to quantify color with CIELAB color space for various purpose. Logger uses ImageJ to analyze the success of patient erythema treatment by comparing L,a,b values before and after treatment which is compared to a standard in the form of clinical score. As a result, with ImageJ, the resulting a value (red-green difference) has a strong closeness with the standard. Our previous research also used ImageJ in obtaining L,a,b values to find out the removal of stain on three types of specimens, which are teeth, artificial teeth, and acrylic resin plate. ImageJ was succeeded to quantify colors and predict stain removal ability, with values that have high accuracy (up to 0.001).

Beside ImageJ, photoshop is also often used to get L, a, b values because it is easy, simple, familiar, and has been widely used. Through the method elaborated in Table 3, it can be seen that the process of getting Lab values with Photoshop is very fast and simple, but the limit, the resulting value has lower accuracy than using ImageJ. In addition, analysis can only be conducted at one point, while in imageJ it is conducted to wider area that is being selected.

Table 4 shows that the two software produced ΔE value which is comparable to each toothpaste group, that is, there is a decrease in the ΔE value as the concentration of the active ingredient (bay leaf essential oil) in the toothpaste increased. This is proven by independent T-test to compare the average of ΔE value which is resulted from the two software, which showed that there was no significant difference between the average of ΔE.
value which is resulted from imageJ and photoshop (p=0.893). This shows that the two software resulted the ΔE value which is almost the same and comparable. To evaluate the accuracy of using the two software by looking the closeness of result obtained from the two software, a Pearson’s correlation test was conducted and a correlation coefficient of R=0.904 was obtained, which means that the two software have strong correlation, that is have significant similarities. Both software are equally qualified to be used in quantifying L,a,b values, which are influenced by the use of controlled and consistent protocol for each sample, including in terms of camera setting, place setting, and area in conducting analysis with software, so that the value resulted in measuring the color difference before and after treatment are truly representative. The use of grid will make it easier in equalize the area which is being analyzed.

**Conclusion**

Both software can be used to obtain accurate and representative L,a,b values and color difference (ΔE). The use of digital imaging combined with software can be an alternative for simple, objective, and accurate color measurements as an alternative in using instruments with strict protocol observance and variable control. Considering the limits of each method, it is recommended to use more than one software or method to ensure the accuracy of color measurement.

**Acknowledgement**

Our gratitude to the Lembaga Pengelola Dana Pendidikan (LPDP), Ministry of Finance of Indonesia, for supporting this research under grant number FR192021263962.

**References:**

12. Sirintawat N, Leelaratrungruang T,


